[TUTO] Mettre à jour sa Switch avec ChoiDujourNX

 
Discutez ici des tutoriaux Switch publiés sur notre portail dédié. Et si vous avez l'âme d'un rédacteur, partagez donc vos propres tutoriaux avec la communauté.
Répondre
Dingoo
Administrateur
Messages : 38
Enregistré le : 09 avr.avr. 2019, 18:17

[TUTO] Mettre à jour sa Switch avec ChoiDujourNX

Message par Dingoo » 21 avr.avr. 2019, 10:23

Image

[TUTO] Mettre à jour sa Switch avec ChoiDujourNX

Si vous souhaitez réagir au sujet de ce tuto, si vous avez besoin d'informations ou des questions, c'est ici que ça se passe !
switchos
Messages : 3
Enregistré le : 03 aoûtaoût 2019, 11:41

Message par switchos » 03 aoûtaoût 2019, 11:46

Bonjour,

Suite à mise à jour de ma switch en 8.0.1 en suivant le tuto, la console ne redémarre plus (elle avait commencé un reboot et s'est éteinte), que ce soit en mode cfw ou mode normal.
J'ai tenté de la poser sur le socle ou connecter un cable usb relié à un chargeur mais rien ne se passe.

Pouvez-vous svp m'aider ?

Merci
Dingoo
Administrateur
Messages : 38
Enregistré le : 09 avr.avr. 2019, 18:17

Message par Dingoo » 04 aoûtaoût 2019, 17:20

Salut, tu es sur que ta console n’est pas bloquée en mode rcm? Tu as essayé de la connecter à ton pc et de lancer tegrarcm?
switchos
Messages : 3
Enregistré le : 03 aoûtaoût 2019, 11:41

Message par switchos » 06 aoûtaoût 2019, 20:09

Bonsoir et merci pour ta réponse (que je n'avais pas vue, désolé)

J'ai réussi à réinjecter Hekate via tegrarcm en connectant au PC et ai pu redémarrer en mode "classique"

Je viens de remettre la console en chargement et vais tenter demain de redémarrer avec l'OS SX.

Faut que je relise les manips à effectuer pour supprimer l'auto rcm et tenter de récupérer les données ou réinjecter la Nand que j'ai sauvegardée.

J'ai réussi à accéder au mode cfw mais la console ne reboote pas et l'écran reste noir....que dois-je faire stp ?
Dingoo
Administrateur
Messages : 38
Enregistré le : 09 avr.avr. 2019, 18:17

Message par Dingoo » 07 aoûtaoût 2019, 14:31

Salut, ta carte micro-SD est en fat32 ou ex-fat ? Si tu as sélectionné 8.0.1 exfat avec ChoidujourNX alors il te faut une carte en exfat sinon ça ne fonctionne pas.

Tu as bien mis sur ta sd la dernière version de SX OS compatible avec la 8.0.1 ?

Pour enlever l'autorcm, tu lances Hekate et dans Tools (de mémoire) tu peux activer ou désactiver l'autoRCM.
switchos
Messages : 3
Enregistré le : 03 aoûtaoût 2019, 11:41

Message par switchos » 07 aoûtaoût 2019, 17:17

Salut et merci pour l'info,

Je vais vérifier tout ça et ferai un retour dès que possible.

Effectivement tu avais raison de me le rappeler, la version sx pro n'était pas à jour.
C'est chose faite et cela semble fonctionner.

Merci encore.
Dingoo
Administrateur
Messages : 38
Enregistré le : 09 avr.avr. 2019, 18:17

Message par Dingoo » 07 aoûtaoût 2019, 19:48

Bonne nouvelle !

De rien ;)
Pline
Messages : 1
Enregistré le : 07 oct.oct. 2020, 15:29

Message par Pline » 08 oct.oct. 2020, 12:00

Bonjour, j'ai besoin d'aide.

J'ai fait la mise a jour avec choidujour et je me suis trompé. J'ai choisi exfat a la place de fat 32.
J'ai pensé a un problème avec hekate donc j'ai mis la version 5.3.3 mais ca ne fonctionne pas. Je peux démarrer en RCM mais après avoir lancé CFW j'ai un message d'erreur.

Pouvez vous m'aider svp
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 08 oct.oct. 2020, 20:53

salut,

le fait de choisir exFAT au lieu de FAT32 n'a absolument AUCUNE incidence sur le démarrage de la console. C'est l'inverse qu'il ne faut pas faire (choisir FAT32 si tu es en exFAT aec une microSD formatée exFAT) :
  • le firmware lit nativement le FAT32, peu importe que tu choisisses FAT32 ou exFAT.
    Par contre le firmware FAT32 ne peut pas lire une microSD exFAT.
tu ne précises pas quel Custom Firmware tu utilises...ni sa version...ni l'erreur que tu obtiens...ni ta méthode de boot...ça va être dur de t'aider en quoi que ce soit sans ces informations.

et si tu as maj ton firmware 9.x vers 10.x, Atmosphère doit IMPÉRATIVEMENT être à jour AVANT toute chose, sinon c'est écran noir ou écran d'erreur.
Kiwwoui
Messages : 2
Enregistré le : 16 oct.oct. 2020, 04:09

Message par Kiwwoui » 16 oct.oct. 2020, 16:02

Bonjour!

Désolé de vous déranger, je rencontre un soucis avec ma switch depuis que je l'ai fait passer de la version 10.1.0 à la 10.2.0 via choixdujoursnx, déjà comme vidéo pour m'aider j'ai utiliser cette vidéo : https://www.youtube.com/watch?v=2eduxI5r-lQ&t=156s

Je vous décris donc mon soucis, comme je suis un débutant dans tout ça et que je ne sais que utiliser SX OS avec un dongle etc c'était assez simple même pour un débutant, cependant j'ai du faire une connerie quelque part car quand j'allume ma console sans custom fw normale il n'y as aucun soucis, la switch s'allume, tout est correcte, mais quand je veut accéder donc au contenue de ma carte, donc en redémarrant la console, et en l'allumant avec le dongle et les manip, donc quand je la lance en custom fw mon écran ne s'allume pas, malgré le fait j'ai respecter toutes les démarches. Je peut cependant rester appuier sur le bouton allumer/éteindre longtemps pour éteindre la console et la redémarré, mais le même résultat quand je relance en custome fw.

J'avais déjà fait une mise à jours de ma console via choixdujournx il y as quelques mois et tout c'était bien passé, je précise que je n'ai pas activé le mode RCM

Je précise donc que je m'y connais très peu, je n'ai toucher à rien de spécial dans les options etc, j'ai sûrement hormis des informations, si vous avez des questions pour pouvoir m'aider n'hésitez pas!
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 16 oct.oct. 2020, 18:44

salut kiwwoui,

tu as mis ta console à jour, mais tu as mis aussi SXOS à jour ? À savoir que le firmware 10.2.0 est supporté uniquement par SXOS 3.0.5beta (et versions ultérieures s'il y en a un jour...pas gagné)

https://www.hackintendo.com/download/sxos/
Kiwwoui
Messages : 2
Enregistré le : 16 oct.oct. 2020, 04:09

Message par Kiwwoui » 17 oct.oct. 2020, 21:19

Merci énormément badablek ! 

C'était exactement sa, tu me sauve! bonne soirée
mitilia
Messages : 1
Enregistré le : 04 nov.nov. 2020, 16:37

Message par mitilia » 04 nov.nov. 2020, 20:24

bonjour tout le monde
je viens de deBricker ma switch en suivant votre tuto :[TUTO] Débricker une Switch sans dump de Nand apres une tentative foireuse pour passer au firmware 10.0.4 via choixdujour. là je suis en fw 5.0.1 mais je ne sais pas quelle etais la version de ma switch
voila je ne sais pas quoi faire ...quelqu'un peut m'aidé
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 04 nov.nov. 2020, 20:48

salut,

si j'ai bien compris, tu as débrické ta console qui avait foiré en 10.0.4, tu as débrické avec le tuto, ce qui fait que tu te retrouves en 5.0.1, et tu veux savoir ce qu'il faut faire maintenant ?

Si c'est bien ça, avec Atmosphère /fusee-primary à jour (0.15.0), tu as le homebrew "daybreak" qui est fourni d'office. Celui-ci est un équivalent à ChoidujourNX, mais qui est à jour, et, dixit les devs d'Atmosphère, bien plus sécurisés (Choi se permet certaines choses hors des sentiers battus, qui peut bricker la console)

Il faut donc lancer daybreak depuis Atmosphère 0.15.0 (démarré avec fusee-primary 0.15.0), et installer le dernier firmware en date (10.2.0). Et tu seras bon.
isarnololaleo
Messages : 3
Enregistré le : 15 déc.déc. 2020, 23:43

Message par isarnololaleo » 15 déc.déc. 2020, 23:49

Bonjour

J'ai suivi le Tuto mais j'ai du rater un truc je suis en sxos 3.1 j'ai installé choidujourNX sans problème je download le firmware 11 et transfert sur ma SD à la racine mais quand je vais sur choidujour pour l'étape suivante je n'ai pas de dossier qui s'affiche juste une image de page blanche avec le nom du fichier "firmware11" mais je peux pas le sélectionner "choose" ?? merci pour votre aide
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 16 déc.déc. 2020, 00:49

salut,

je vais poser une question peut-être bête...mais à tout hasard : tu as bien décompressé l'archive du firmware ? Tu parles d'un fichier 11.0.0, ce qui met le doute.

Il faut impérativement que la mise à jour soit décompressée pour qu'elle puisse être lue par ChoiduJourNX
isarnololaleo
Messages : 3
Enregistré le : 15 déc.déc. 2020, 23:43

Message par isarnololaleo » 16 déc.déc. 2020, 15:25

Bonjour

Oui avec Mac c'est automatique la décompression je transfère bien un dossier avec des fichiers .NCA je devrais avoir un dossier comme sur le tuto mais non juste une icône de page blanche non selectionnable ?
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 16 déc.déc. 2020, 20:09

les MAC sont réputés pour ajouter des fichiers/dossiers poubelle tout en modifiant le bit "archive" des fichiers, ce qui est problématique avec les homebrews.

https://gbatemp.net/threads/how-to-fix- ... rs.515258/


Sinon Hekate dispose d'une option pour corriger le bit "archive" (mais je ne sais pas s'il l'applique à toute la SD ou seulement une partie.
isarnololaleo
Messages : 3
Enregistré le : 15 déc.déc. 2020, 23:43

Message par isarnololaleo » 21 déc.déc. 2020, 17:33

Merci j'ai réussi à bloquer le console :( j'ai installé comme indiqué sur le TUTO le dernier firmware 11.0.1 mais elle ne redémarre plus écran noir ... mon fils va me tuer  :roll:
 
 
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 21 déc.déc. 2020, 19:46

je ne comprends pas un truc...pourquoi installer un firmware 11.0.1 alors même que SXOS, dans sa version la plus récente (3.1.0) NE LE SUPPORTE PAS ? Alors même qu'aucun jeu ne le nécessite ?

j'ai bien parlé du firmware 11.0.0 plus haut, c'était pour une bonne raison  :dubitatif:
 

tu es bon pour attendre une hypothétique mise à jour de SXOS...
guitwo
Messages : 2
Enregistré le : 18 marsmars 2021, 16:23

Message par guitwo » 18 marsmars 2021, 17:30

Du coup j'ai fait la maj du firmware 10.2.0 au 11.0.1 (c'était marqué qu'il le fallait pour faire tourner super mario 3D world + bowser's fury  :dubitatif: ). Si je comprend bien je ne peux pas la downgrader en 11.0.0 à cause des efuses ?

Est-ce que quelqu'un aurait une solution pliz  :roll:  ou des news d'une éventuelle maj du custom firmware ?
 
Avatar du membre
badablek
Administrateur
Messages : 238
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 19 marsmars 2021, 00:59

une mise à jour ne brûle pas systématiquement d'efuse...les firmwares 11.0.0 et 11.0.1 partagent le même nombre d'efuses (14), et en cherchant un peu, tu trouveras plusieurs sujets où j'explique justement qu'il est possible de downgrader en 11.0.0

l'autre solution, c'est de passer à Atmosphère...tu devras de toute façon l'utiliser pour downgrader. Il faut juste accepter de lâcher les XCI montables en temps réel (AMS ne supporte que les jeux installés)
guitwo
Messages : 2
Enregistré le : 18 marsmars 2021, 16:23

Message par guitwo » 19 marsmars 2021, 09:47

Ok je vais regarder ça merci beaucoup  ;)
Carl93
Messages : 1
Enregistré le : 14 avr.avr. 2021, 15:27

Message par Carl93 » 14 avr.avr. 2021, 15:30

Hello, je n'arrive pas a trouver le fichier ChoiDuJourNX dans l'onglet homebrew, pourtant j'ai bien copier le fichier dans le dossier switch. Et la SD est bien en exfat.

Savez-vous pourquoi? 

Merci
ndjembe
Messages : 26
Enregistré le : 24 oct.oct. 2019, 12:11
Localisation : Arrière Pays Niçois

Message par ndjembe » 14 avr.avr. 2021, 18:53

Bonsoir @Carl93

Il se peut que vous ayez eu un soucis dans le transfert de cet homebrew qui doit être au format nro l'avez vous dézippé avant de le mettre dans le dossier? Ma question sera peut être absurde mais on ne sait jamais. Refaite donc une recherche de cet homebrew sur le net et prenez bien la version 1.0.2. Je ne vois pas de raison qui ferait que vous ne puissiez pas trouver le "petit lapin blanc". Retentez une recherche de source et regarder si il est toujours sur votre carte SD avec une taille convenable et non 0kb si c'est le cas refaite juste le transfert vers votre SD. Dans l'attente
Bonne soirée à vous
Répondre