(Demande) hbmenu vide

 
Discutez ici des logiciels gravitant autour du hack de la Switch. N'hésitez pas à poser vos questions, à partager vos trouvailles, conseils ou bonnes pratiques, etc.
 
Répondre
strategos323
Moussaillon
Réactions :
Messages : 3
Enregistré le : 25 janv.janv. 2024, 07:19

(Demande) hbmenu vide

Message par strategos323 » 25 janv.janv. 2024, 08:21

Bonjour à tous

J'ai besoin de votre aide car je suis novice en switch et informatique, je suis perdu dans tous les tutos et les différentes pages de ce forum.

Tout d'abord voici la liste de mon matériel :
Macbook pro de 2018
Switch V1 n° série XAJ7000xxxxxx(qui serait donc non patchée)
micro SD Sandisk XC 128 Go

Voici le tuto que j'ai suivi ainsi que les étapes réalisées :

tuto youtube de Doudou COMMENT CRACKER SA SWITCH EN 5 MIN ET INSTALLER DES JEUX - DÉCEMBRE 2023 FR 17.0.1

étant sur MAC et ayant bien compris le risque de l'exFAT j'ai formaté ma micro SD en ms-dos (car j'ai cru comprendre que c'était du FAT32 mais c'est peut être ma première erreur)

j'ai copié sur cette SD les fichiers du tuto :
dossier atmposphere
dossier bootloader
exosphere.ini
hbmenu.nro
dossier switch avec daybreak.nro, DBI.nro, haze.nro et reboot_to_payload.nro

je mets la carte sd dans la console
j'ai mis un jailbreak(plug plastique) dnas le slot de droite de la console, je maintines volume + et power => la console ne s'allume pas

étant sur mac je ne peux pas installer TEGRARMCGUI.exe, j'ai donc utilisé google chrome et
https://atlas44.s3-us-west-2.amazonaws. ... index.html
sur cette page dansd upload payload j'ai utilisé le fichier hekate_ctcaer_6.0.7 (avec la console switch connectée en USB)

j'allume la console qui se lance en mode RMC

j'ai suivi le tuto : régler date et heure, cliquer sur emuMMC, sdfile ==> une sauvegarde s'est alncée (cela a pris 45mns)
j'ai fermé ça, cliqué sur launch puis CFW - emuMMC

la console se lance en mode normal (et cela prend plusieurs minutes)

quand je vais dans galerie, il y a bien la fenêtre hbmenu mais celle ci est vide => pas de DBI, daybreak ou autre

un message s'affiche comme quoi il manque un dossier switch sur la carte sd (et pourtant j'en ai bien un avec daybreak, dbi haze et reboot to payload en nro)



en lisant les différents forums je suis complètement perdu, on parle de faire un fichier switch dans la racine mais je bugge complètement

pourriez vous me sauver svp ?

merci d'avance

 
Avatar du membre
badablek
Capitaine
Réactions :
Messages : 1474
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 25 janv.janv. 2024, 20:42

salut,

tu l'as achetée où ta microSD ? Et à quel prix ? Les lenteurs dont tu parles sont totalement anormales avec une microSD de bonne qualité...sauf si c'est une fake card que tu as pris (raison de mes deux questions).

Le dump de la sysMMC ne prend pas plus de 25 minutes avec la version actuelle, 45 minutes, c'est encore plus anormal !

macOS étant spécialiste pour créer des dossiers parasite invisibles, il peut interagir négativement avec Atmosphère, qui ne retrouve pas ses petits. Dans Hekate, tu peux tenter la fonctionnalité "Fix bit archive" dans "Tools"



Je ne connais absolument pas macOS, mais il existe un client pour injecter un payload, voir ici


enfin, n'étant pas le SAV d'une chaîne youtube parmi tant d'autres, je t'invite à consulter les tutos du site.
strategos323
Moussaillon
Réactions :
Messages : 3
Enregistré le : 25 janv.janv. 2024, 07:19

Message par strategos323 » 26 janv.janv. 2024, 06:44

Bonjour badablek

merci bien pour ton aide.

Tout d'abord pour te répondre, la micro sd je l'ai achetée à un client (je travaille dans un magasin qui achète et vend des produits d occasion à 5 euros. Je ne pense pas que la personne m'a arnaquée, par contre j'ignore complètement où lui l'a achetée. Je sais juste qu'il l'utilisait pour sa propre switch.

Finalement après pas mal d'essau(dans la limite de mes faibles connaissances) j'ai réussi à avoir accès aux fichiers NRO par hbmenu.
J'ai lancé MTP responder mais la console n'est pas visible sur mon mac.

J'ai télécharger CrystalRCM mais mon mac me dit que le fichier est endommagé (mais peut être que je n'en ai pas besoin).

en effet tu as raison, je suis navré, tu n'es pas là pour faire le sav d'un tuto youtube mais le site hackintendo m'a paru sérieux et de confiance donc c'est pour cela que  je me suis permis de demander de l'aide.

Hier j'ai passé du temps sur le forum et navré je n'ai pas trouvé de pages expliquant le process en détail pour les macs.

Merci d'avance

 
Avatar du membre
badablek
Capitaine
Réactions :
Messages : 1474
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 26 janv.janv. 2024, 14:14

le souci avec MacOS, c'est que ça reste un marché de niche, et comme la virtualisation est très compliquée (nécessite énormément de bidouilles), il est difficile de proposer des tutos adaptés à cet environnement.

Pour le "SAV", je voulais dire par là que je ne sais pas ce qu'il raconte dans sa vidéo, et que je ne peux pas m'amuser à la décortiquer pour savoir où ça pêche  ;)

mais du coup, je serai bien curieux de savoir ce que tu as fait pour corriger le souci. Et je ne m'explique toujours pas les lenteurs que tu expérimentes (à moins que la microSD soit vraiment très très lente !).
strategos323
Moussaillon
Réactions :
Messages : 3
Enregistré le : 25 janv.janv. 2024, 07:19

Message par strategos323 » 27 janv.janv. 2024, 07:55

Hello

je comprends la problème avec mac. je pensais, peut être un peu naïvement, que comme depuis 15 ans les possesseurs de macbook sont beaucoup plus nombreux, que je trouverais bien plus de tutos et de solutions adaptées à ces machines.

Concernant le SAV, il n'y a aucun problème 😉. je comprends tout à fait ta remarque.

Concernant la solution, car depuis hier matin j'ai réussi, la solution parait simple. Tout d'abord j'ai téléchargé un autre pack hack venant d'une autre personne, ce pack étant normalement fait pour la version de ma switch.

Puis je crois avoir fait l'erreur de nommer ma carte SD "switch" et en changeant ce nom, les fichiers nro sont apparus dans hbmenu. La switch n'apparaissait pas d'abord sur mon mac (par l'intermédiaire de Android File Transfer), j'ai alors cherché d'autres logiciels comme openmtp mais cela ne marchait toujours pas. J'ai alors redémarré mon mac et ça a marché

J'ai tenté de copier 4 jeux hier pour un total de 24go, cela m'a annoncé un délai de 2 heures et finalement 3 jeux sur 4 ont marché.

J'ai copié hier soir seulement la 4ème jeu et ça marche. J'ai donc l'impression qu'il ne faut aps copier trop de fichiers d'un coup.

Donc je suis bien content.

maintenant il faut que je trouve breath of the wild en français car mon site habituel n'a pas tous les liens fonctionnels.

Encore merci pour ton aide et bon weekend
 
Avatar du membre
badablek
Capitaine
Réactions :
Messages : 1474
Enregistré le : 08 avr.avr. 2019, 20:19
Localisation : Nancy

Message par badablek » 27 janv.janv. 2024, 09:50

l'histoire de nommer la microSD "switch" me dit effectivement quelque chose...mais je n'aurais jamais eu le réflexe de te demander le nom choisi (je note dans un coin de tête). Intéressant de savoir que ça affecte la lecture du dossier switch (et donc de tous les homebrews)

quand tu parlais de ton souci, je pensais que tu avais téléchargé les différentes briques qui composent le hack directement à la source. J'aurais dû me méfier de ces tutos youtube avec un pack clé en main bourré de cochonneries et très certainement périmé...pour ce cas bien précis, je ne peux que te donner un conseil : TOUJOURS télécharger à la source (OU sur n'importe quel site proposant uniquement les zip non modifiés, comme sur hackintendo)

le hack, c'est : bootloader (fusée et/ou hekate) / Custom Firmware (Atmosphère) / Sigpatches (adaptées au firmware/Custom Firmware)
C'est tellement simple qu'un pack AIO n'a aucune valeur, si ce n'est ajouter des choses qu'on ne veut pas forcément (parce que la vision du hack de celui qui fait le pack AIO ne correspondra jamais 1:1 à tes attentes à ce sujet)


Vu les délais que tu m'annonces, ta carte tourne à peu près à 3,5Mo/s, ce qui est anormalement bas (et je comprends pourquoi tout est lent à démarrer). Je ne peux que te conseiller d'acheter une microSD de qualité, récente ! Sans forcer et sans activer l'USB3, je tourne entre 15 et 20Mo/s (et 45Mo/s en activant USB3...si on accepte les ennuis que ça provoque). Celles vendues aux couleurs de Nintendo sont un bon moyen de voir quelles caractéristiques il faut privilégier (quand elles sont en promo, elles valent le coup/coût...mais hors promo, ça fait cher le rebadgage)


ps : le mode MTP ne demande logiquement que le pilote Android à installer sur macOS (mais encore une fois, je suis une bille sur ce système, je ne fais que répéter ce que j'ai pu lire), c'est étonnant que ça ne suffise pas (et ça me dépasse...le mode MTP est un standard...en tout cas pour Linux et Windows...encore Apple qui fait à sa sauce, dans son coin  :angry: )
Répondre